Table of Contents

Automatically match image colors

The machine learning-powered ML Match Colors feature lets you match colors of one image to the colors of another image. You can match colors of images, clipboard items, selections, shapes, or text to any other images or graphics on your device or the web. The ML Match Colors algorithm analyzes the source and the target images and then applies a wide range of color adjustments to match their lighting, contrast, and color balance.


Match colors of two images or layers

  1. You can match colors with single layer or, using a color adjustments layer, with multiple layers in a composition.

    To mach colors with the currently selected layer, do one of the following:

    • Choose Format > Color Adjustments > ML Match Colors (from the Format menu at the top of your screen).
    • Click in the Tools sidebar and choose ML Match Colors from the More menu at the top of the Color Adjustments pane.

To match colors with multiple layers in a composition using a color adjustments layer (all layers below this layer will be affected):

  • Choose Insert > Color Adjustments (from the Insert menu at the top of your screen) and choose ML Match Colors from the More menu at the top of the Color Adjustments pane.
  • Click at the top of the Layers sidebar, choose Color Adjustments, and choose ML Match Colors from the More menu at the top of the Color Adjustments pane.

2. In the dialog, choose an image to use for color matching and click ML Match Colors. Alternatively, you can also drag an image from your Layers sidebar, desktop, Finder, web browser, or macOS Photos app to the Color Adjustments pane.

Match colors with Clipboard items
  1. Copy an item (a selection, shape, text or other) you want to match to the Clipboard.
  2. Open an image to which you'd like to match the colors.
  3. Do one of the following:

    • While holding down the Control ⌃ key, choose Edit > Paste and ML Match Colors (from the Edit menu at the top of your screen).
    • Press Control ⌃ + Option ⌥ + Shift ⇧ + Command ⌘ + V on your keyboard.

    You can manually adjust any of the 37 color adjustments available in the Color Adjustments pane, delete or add new ones.

Pixelmator Pro User Guide