Search Results

Use alignment guides

When moving and sizing layers, smart spacing and sizing guides automatically appear to help you precisely place and resize layers. They are invisible most of the time and only appear if you move or resize a layer in your image and it becomes a similar size or equidistant to another layer. You can also add persistent alignment guides that are always visible in your image. Certain guides are turned on by default and other, additional guides can be turned on or off in Pixelmator Pro preferences.

Turn on Smart Guides

Smart Guides appear when a layer or a layer group matches the size or position or another layer or layer group. Smart Guides can also help equally space three or more objects in a line.

  1. Do one of the following:
    • Choose Pixelmator Pro > Preferences (from the Pixelmator Pro menu at the top of your screen), then click the Rulers tab.
    • Choose View > Guides (from the View menu at the top of your screen.
  2. Select any of the options:
    • Show guides at object center: Guides appear when the center of an object aligns with the center of another object or the center of the image.
    • Show guides at object edges: Guides appear when the edges of an object align with the edge of another object or an edge of the image.
    • Show guides for relative sizing: Guides appear when an object matches the size of another object.
    • Show guides for relative spacing: Guides appear when three or more objects are placed equally apart in a line.

Tip: If you want, you can change the color of the Smart Guides in Pixelmator Pro preferences.

Add persistent alignment guides

You can add alignment guides that remain visible on your image while you’re working, even if you close the image and return to it later. You can add as many guides as you like and position them to suit your needs. Alignment guides are unique to each image you edit.

To add a guide, do one of the following:

  • Click in the Pixelmator Pro toolbar, then choose Show Rulers. Move the pointer over the vertical or horizontal ruler, then drag to the image.
  • Control ⌃–click the vertical or horizontal ruler, and choose Add Guide.
  • Double-click a ruler, choose the orientation and position of the ruler, and click OK to add the guide.
  • Choose View > Guides > Add Guide (from the View menu at the top of your screen). Choose the orientation of the guide and type in its position. Click OK to add the guide.

Tip: If you want, you can change the color of the alignment guides in Pixelmator Pro preferences.

Change the location of a persistent alignment guide
  1. Choose the Arrange tool by doing one of the following:
    • Click in the Tools sidebar.
    • Choose Tools > Arrange (from the Tools menu at the top of your screen).
    • Press the V key on your keyboard.
  2. Drag a guide.
Remove or hide persistent alignment guides

Do any of the following:

  • Remove a horizontal guide: Drag it to the top of the image.
  • Remove a vertical guide: Drag it to the left of the image.
  • Show or hide all guides: Choose View > Hide Guides (from the View menu at the top of your screen).
 To show all guides, choose View > Show Guides.

Lock guides

You can lock the persistent guides you've added to the image to avoid accidentally moving them.

  • Choose View > Guides > Lock Guides (from the View menu at the top of your screen).
Clear guides

Remove all persistent guides from the image.

  • Choose View > Guides > Clear Guides (from the View menu at the top of your screen).

Pixelmator Pro User Guide