Search Results

Add an inner shadow to a layer

The Inner Shadow layer style adds a drop shadow inside your selected layer, giving it a recessed or hollowed-out appearance.


Add an inner shadow to a layer

  1. Select the layer or layers you would like to edit.
  2. Choose the Style tool by doing one of the following:
    • Click in the Tools sidebar.
    • Choose Tools > Style (from the Tools menu at the top of your screen).
    • Press the S key on your keyboard.
  3. Select the Inner Shadow checkbox or click the Add menu in the top right of the Tool Options pane and choose Inner Shadow. You can also choose Format > Styles > Inner Shadow (from the Format menu at the top of your screen).

    Using the Add menu, you can also add additional Inner Shadow layer styles to a single layer.

  4. Customize the Inner Shadow layer style:

    • Blur: Move the Blur slider to adjust how much to soften the edges of the shadow. You can also enter a value from 0 px to 100 px.
    • Distance: Move the Distance slider to adjust how far the shadow is from the object. Hold down the Option ⌥ key to extend the range of the Distance slider. You can also enter a value from 0 px to 400 px.
    • Angle: Move the Angle wheel to change the angle of the shadow. You can also enter a value between 0º and 359.9º.
    • Color: Click the color well to choose a color or click to open the Colors window.
    • Opacity: Move the slider to adjust the transparency of the shadow. You can also enter a value between 0% and 100%.
    • Blend Mode: Click the Blend Mode pop-up menu to choose a different blend mode.
  5. If you have applied multiple Inner Shadow layer styles to a single layer and you’d like to rearrange them, click the Inner Shadow pop-up menu and choose Bring Forward, Bring to Front, Send Backward, or Send to Back.


To reset or remove an Inner Shadow layer style, click the Inner Shadow pop-up menu in the Tool Options pane and choose Reset or Remove Style.

Pixelmator Pro User Guide