Search Results

Add an outline around a layer

The Stroke layer style adds a customizable outline around your selected layer.


Add an outline around a layer

  1. Select the layer or layers you would like to edit.
  2. Choose the Style tool by doing one of the following:
    • Click in the Tools sidebar.
    • Choose Tools > Style (from the Tools menu at the top of your screen).
    • Press the S key on your keyboard.
  3. Select the Stroke checkbox or click the Add menu in the top right of the Tool Options pane and choose Stroke. You can also choose Format > Styles > Stroke (from the Format menu at the top of your screen).

    Using the Add menu, you can also add additional Stroke layer styles to a single layer.

  4. Customize the Stroke layer style:

    • Stroke Width: Drag the Stroke Width slider to adjust the width of the outline. Hold down the Option ⌥ key to extend the range of the Stroke Width slider. You can also enter a value from 1 px to 200 px.
    • Stroke Position: Click the Position pop-up menu below the Stroke Width slider to choose the position of the outline. Inside makes the outline expand into your selected layer, Center makes it expand both inwards and outwards from the edges of the layer, and Outside makes the outline appear entirely outside your selected layer.
    • Stroke Style: Click the Stroke Style pop-up menu to the right of the stroke position menu and choose a solid, dashed, or dotted outline.
    • Stroke Fill: Click the Fill pop-up menu below the Stroke Style pop-up menu and choose either a Color stroke for a solid color outline or Gradient to fill the outline with a transition between multiple colors.
    • Stroke Color: Click the color well to choose a color or click to open the Colors window.

  5. If you have applied multiple Stroke layer styles to a single layer and you’d like to rearrange them, click the Stroke pop-up menu and choose Bring Forward, Bring to Front, Send Backward, or Send to Back.


To reset or remove a Stroke layer style, click the Stroke pop-up menu in the Tool Options pane and choose Reset or Remove Style.

Pixelmator Pro User Guide