Search Results

Edit from Photos

You can send images from the Photos app to edit in Pixelmator Pro and then save the changes back to the original image in your library.


Open an image from Photos

  1. Open the Photos app.
  2. Find the image you want to edit and click to select it.
  3. Do one of the following:

    • Choose Image > Edit With > Pixelmator Pro (from the Image menu at the top of your screen).
    • Control ⌃-click a photo and choose Edit With > Pixelmator Pro.

To save your changes back to the original image, choose File > Save in Pixelmator Pro.


When saving images back to Photos, Pixelmator Pro does it in the JPEG file format by default, so all the layers, adjustments, effects, styles, and other formatting you add to the image are merged. To keep the nondestructive edits and layers, choose File > Export (from the File menu at the top of your screen) and export the image to the Pixelmator Pro file format. You can also edit your photos right in the Photos app using the Pixelmator Pro Photos extension.

Pixelmator Pro User Guide