Search Results

Select precise areas of an image

There are a number of different ways to make selections in Pixelmator Pro. The basic selection tools, like the Rectangular Selection or Elliptical Selection tools, let you select simple rectangular or elliptical areas. Other, more advanced selection tools, such as the Quick Selection or Magnetic Selection tool, select areas of an image according to their content — colors, contours, and more.

Quickly select an object or area in an image
  1. Choose the Quick Selection tool by doing one of the following:

    • Click in the Tools sidebar or choose it from the grouped tools.
    • Choose Tools > Quick Selection (from the Tools menu at the top of your screen).
    • Press the Q key on your keyboard.
  2. In the Tool Options pane, customize the options for the Quick Selection tool:

    • Brush Size: Change the size of the selection brush — the larger the brush, the larger the area will be selected.
    • Sample All Layers: Select to make the Quick Selection tool make selections based not just on the active layer, but your entire visible image.
    • Live Tracking: Select to show a preview of the initial selection before you make it.
  3. Draw over an area or an object you'd like to select.

Snap a selection around an object or area in an image

The Magnetic Selection tool is used to trace selections around objects and areas in images as it snaps to any contours or edges.

  1. Choose the Magnetic Selection tool by doing one of the following:

    • Click in the Tools sidebar or choose it from the grouped tools.
    • Choose Tools > Select > Magnetic Selection (from the Tools menu at the top of your screen).

    Tip: You can cycle through Magnetic, Free, and Polygonal selection tools by pressing Shift ⇧ + L on your keyboard.

  2. In the Tool Options pane, customize the options for the Magnetic Selection tool:

    • Sample All Layers: Select to make the Magnetic Selection tool make selections based not just on the active layer, but your entire visible image.
  3. Click in your image to add anchor points and guide your selection around the object or area you'd like to select. To reselect an anchor point, click the last added point to remove it, then click to add a new anchor point.

    To complete your selection, click the first anchor point or press the Return ↵ key.

Draw a freehand selection
  1. Choose the Free Selection (or the lasso) tool by doing one of the following:

    • Click in the Tools sidebar or choose it from the grouped tools.
    • Choose Tools > Select > Free Selection (from the Tools menu at the top of your screen).
    • Press the L key on your keyboard.

    Tip: You can cycle through Magnetic, Free, and Polygonal selection tools by pressing Shift ⇧ + L on your keyboard.

  2. Drag in your image to draw a selection. To reselect an anchor point, click the last point to remove it, then continue drawing.

Make a straight-edged selection
  1. Choose the Polygonal Selection tool by doing one of the following:

    • Click in the Tools sidebar or choose it from the grouped tools.
    • Choose Tools > Select > Polygonal Selection (from the Tools menu at the top of your screen).
    • Press the L key on your keyboard.

    Tip: You can cycle through Magnetic, Free, and Polygonal selection tools by pressing Shift ⇧ + L on your keyboard.

  2. Click in your image to add straight selection lines to make your selection.

  3. Click the start of the selection to finish it. Alternatively, double-click anywhere in your image or press the Return ↵ key.

Select similarly colored areas of an image
  1. Choose the Color Selection tool by doing one of the following:
    • Click in the Tools sidebar or choose it from the grouped tools.
    • Choose Tools > Select > Select Color (from the Tools menu at the top of your screen).
    • Press the W key on your keyboard.
  2. In the Tool Options pane, customize the options for the Select Color tool:
    • Sample All Layers: Select to make the Select Color tool make selections based not just on the active layer, but your entire visible image.
    • Smooth Edges: Select to naturally smooth the selection outline.
  3. Drag in your image to make a selection.

If you'd like to select areas in an image within a specific color range, click Select Color Range at the bottom of the Tool Options pane.

Make a rectangular selection
  1. Choose the Rectangular Selection tool by doing one of the following:
    • Click in the Tools sidebar or choose it from the grouped tools.
    • Choose Tools > Select > Rectangular Selection (from the Tools menu at the top of your screen).
    • Press the M key on your keyboard.
  2. Drag in your image to make the selection.

Make an elliptical selection
  1. Choose the Elliptical Selection tool by doing one of the following:
    • Click in the Tools sidebar or choose it from the grouped tools.
    • Choose Tools > Select > Elliptical Selection (from the Tools menu at the top of your screen).
    • Press the Y key on your keyboard.
  2. Drag in your image to make the selection.

Select the entire image

To select the entire image or canvas, do one of the following:

  • Choose Edit > Select All.
  • Press Command ⌘ + A on your keyboard.
Select all the opaque areas of a layer

To select all nontransparent areas of a layer or any opaque areas of a layer mask, do one of the following:

  • Choose Edit > Load Selection.
  • Choose Tools > Select > Load Selection.
  • Press Command ⌘ + Option ⌥ + L on your keyboard.
Deselect a selection

To deselect any active selections on a canvas, do one of the following:

  • Choose Edit > Deselect (from the Edit menu at the top of your screen).
  • Press Command ⌘ + D on your keyboard.
Select a color range

The Select Color Range tool lets you select all similarly-colored areas of an image.

  1. Choose Edit > Select Color Range (from the Edit menu at the top of your screen).
  2. Click the canvas to pick a color range, or click the color well in the Tool Options pane to choose a specific color.
  3. Drag the Range slider to adjust how many of the colors similar to your selected color should be selected.

Pixelmator Pro User Guide