Table of Contents

Change the Pixelmator Pro layout

The Pixelmator Pro workspace is freely customizable — you can change the arrangement of different interface elements such as the Layers sidebar, Tool Options pane, and the Tools sidebar to find a layout that best suits your editing style.


Rearrange your workspace

  1. Do one of the following:

    • Choose Window > Workspace Layout and choose from the existing layouts.
    • Choose Window > Workspace Layout > Workspace Preferences
    • Choose Window > Customize Layout (from the Window menu at the top of the screen).
    • In the Pixelmator Pro Workspace preferences, select a layout you'd like to customize or click to add a new layout preset, then click Customize Layout.
    • Control ⌃ – click the Pixelmator Pro toolbar and choose Customize Layout.
  2. In the layout customization window, drag any of the highlighted elements to start rearranging the workspace. If you simply click and hold an element, special indicators will appear suggesting where you can move it.

    For instance, the Tools sidebar will snap to any edge of the application window, while the Tool Options pane and the Layers sidebar can be placed on the left or the right side of the screen.


To revert any changes made to the original layout, click Reset at the bottom of the layout customization window.

Pixelmator Pro User Guide