Search Results

Fill a layer with a color or gradient

The Fill layer style fills the area of your selected layer with a color or gradient.


Fill a layer with a color or gradient

  1. Select the layer or layers you would like to edit.
  2. Choose the Style tool by doing one of the following:
    • Click in the Tools sidebar.
    • Choose Tools > Style (from the Tools menu at the top of your screen).
    • Press the S key on your keyboard.
  3. Select the Fill checkbox or click the Add menu in the top right of the Tool Options pane and choose Fill. You can also choose Format > Styles > Fill (from the Format menu at the top of your screen).

    Using the Add menu, you can also add additional Fill layer styles to a single layer.

  4. Customize the Fill layer style:

    • Fill Type: Click the pop-up menu below Fill and choose either Color to fill the layer with a solid color, or Gradient to fill it with a transition between multiple colors.
    • Color: Click the color well to choose a color or click to open the Colors window.
    • Opacity: Move the slider to adjust the transparency of the fill. You can also enter a value between 0% and 100%. 

    • Blend Mode: Click the Blend Mode pop-up menu to choose a different blend mode.
  5. If you have applied multiple Fill layer styles to a single layer and you’d like to rearrange them, click the Fill pop-up menu and choose Bring Forward, Bring to Front, Send Backward, or Send to Back.


To reset or remove a Fill layer style, click the Fill pop-up menu in the Tool Options pane and choose Reset or Remove Style.

Pixelmator Pro User Guide