Search Results

Add and edit custom shapes

Pixelmator Pro comes with a collection of custom vector shapes — rectangles, speech bubbles, arrows, and other graphics. Some of these shapes also have smart controls that you can use to quickly customize the shape; those shapes are called Smart Shapes. The most commonly used shapes can be found in the list of tools in the Tools sidebar and even more shapes can be found in the Shapes palette.

Insert a custom shape

Do one of the following:

  • Click Add in the Pixelmator Pro toolbar, then choose one of the shapes in the Shape menu.
  • Chose Insert > Shape and pick one of the options there.
  • Choose Tools > Draw and pick one of the options there.
  • Control ⌃–click the Shape tool in the Tools sidebar and choose a shape.
  • Insert a shape from the Shapes palette (shown below). To open the Shapes palette, choose View > Show Shapes (from the View menu at the top of your screen).

Click or drag on the canvas to add the selected shape.

Tip: To switch from drawing to selecting shapes, hold down the Command ⌘ key on your keyboard.

Customize the look of a Smart Shape

Smart Shapes have green handles that let you quickly customize the appearance of the shape, for example, by adjusting the corner radius of a rounded rectangle, the number of points in a star, or the shape of an arrowhead.

The Pixelmator Pro Smart Shapes are the Rounded Rectangle, Triangle, Polygon, Rhombus, Star, Double-Headed Arrow, Arrow from Point, Arrow, Elliptical Speech Bubble and Rectangular Speech Bubble. To customize a Smart Shape, simply drag one of its green handles.

Edit a shape

There are several ways you can edit shapes in Pixelmator Pro:

  • Use Arrange tool to move, resize, flip, or rotate the shape.
  • Use the Transform tool to freely transform the shape, stretch, skew, or change its perspective.
  • Make the shape editable and adjust individual anchor points of the shape.
Draw or select shapes

When working with shapes or drawing tools, you can easily switch between drawing and selecting by holding down the Command ⌘ key on your keyboard.

  • Draw mode — Lets you draw shapes or paths. You can also resize or rotate the last added shape.
  • Select mode — Lets you select, move, rotate and resize shapes or paths.

To select and move multiple shapes at a time, press and hold Command ⌘ + Shift ⇧ then click or drag to select the shapes. After selecting, press and hold the Command ⌘ key and drag the shapes to position them.

Pixelmator Pro User Guide