Search Results

Choosing colors

There are two ways you can choose colors in Pixelmator Pro — using the Pixelmator Pro color picker and the macOS Colors window. There's also a separate Color Picker tool you can use to manage colors and color palettes, change the color picker settings, and more.

Pixelmator Pro color picker

The Pixelmator Pro color picker lets you quickly choose colors for different tools, color adjustments, or effects, and appears when you click any color well.

The tool consists of two main sections — Color Picker and Swatches. The top section features an eyedropper for picking colors, the color square with a hue slider for choosing a custom color, and the HEX and RGB color code fields for entering specific color values. In the Swatches section, you can choose a color from the existing color palettes or reuse some of your recently selected colors.

  • Find the value of a color: Click , then hover the pointer over the color to see its value or click to pick it. The color value changes as you move from one color to another on the canvas.

  • Choose a color: Click a color swatch in a selected color palette, or use the hue slider and the color field to choose a custom one. The color picker uses the HSB-based (hue, saturation, brightness) color model, so to choose a color, you drag the hue slider, then specify its saturation and brightness by moving a point in the color field above. You can also enter HEX or RGB values to choose a specific color.

  • Manage the color palettes: Click the Color Palettes pop-up menu to browse your existing palettes or click the adjacent Action pop-up menu to remove, rename, and add new palettes.

  • Save colors to use again: In the list of color swatches, click . This adds the currently selected color to the color palette. You can also drag a swatch from the recently selected colors to the color palette directly.

Use the Color Picker tool

If you're looking to manage your color palettes and swatches more easily, or if you'd like to change how color picker samples colors or what information it displays, you can choose a Color Picker tool and change these settings.

  1. Choose the Color Picker tool by doing one of the following:

    • Click in the Tools sidebar.
    • Choose Tools > Color Picker (from the Tools menu at the top of your screen).
    • Press I on your keyboard.
  2. Do any of the following:

    • Adjust the color picker sample size: "1 point sample" selects color from a single pixel in an image. You can also choose "3 by 3 average" or "5 by 5 average" to read the average value of the area within the adjacent 3 by 3 or 5 by 5 pixels.
    • Choose the color picker color values: Under Color Code, choose "RGB" to use RGB codes when displaying color values, or "HEX" to use the web-safe HEX codes.
    • Show color names: Select the "Show closest color name" checkbox to show a color name closest to the picked color value, or deselect to hide it.

Note: Pixelmator Pro remembers the settings you choose, the swatches you add, or the color palettes you create, so you can work with the same settings and colors across multiple documents.

Colors window in Pixelmator Pro

You can use the macOS Colors window in Pixelmator Pro, to access to the native macOS color pickers such as the color wheel, sliders, or pencils.

The Colors window has four sections: the different color pickers at the top (color wheel, color sliders, color palettes, image palettes, and pencils); the active color picker in the middle; the large color swatch in the lower-left to show the currently selected color; the eyedropper for picking colors; and the row of boxes to pick or save new color swatches.

  1. Open the Colors window by doing one of the following:
    • Click next to any color well.
    • Choose View > Show Colors (from the View menu at the top of your screen)
    • Press Shift ⇧ + Command ⌘ + C on your keyboard.
  2. Do any of the following:
    • Choose a color for a selected text, shape, color adjustment, or effect: Click the color picker tab at the top of the Colors window, then choose a color. You can specify a more precise color by using the sliders or entering values.
    • Pick a color: Click the eyedropper, then click anywhere on the computer screen to choose a color.
    • Save colors to use again: At the bottom of the Colors window, drag the color from the larger color swatch on the left to an empty well on the right. To remove a color, drag it to Trash. Colors saved to the color swatches library remain accessible across applications and restarts.

Important: Colors in the color wells update based on the tool or the layer selected, so if you select a color for one tool, the colors don't change for others (except for the painting tools). Consequently, if you leave the Colors window open for one tool, and select another object in the canvas, clicking colors in the already open Colors window does not change the newly selected object.

Gradients palette

When working with shapes, layer styles, or the Gradient Fill tool, you can use a transition between two or more colors, instead of a single color. You can choose from the gradient presets that come with Pixelmator Pro or create and save your own using the Gradients palette.

  1. Open the Gradients palette by doing one of the following:
    • Click the Gradient color well in the Tool Options pane.
    • Choose View > Show Gradients (from the View menu at the top of your screen).
  2. Click an existing gradient to edit it.
  3. Choose the gradient type:

    Linear gradient — Blends colors between color stops, all along a line.

    Radial gradient — Blends from start to end in a circular pattern.

    Angle gradient — Blends colors in a sweep.

  4. Color stops represent your color settings along a spectrum that you create. A gradient will always have at least two colors. You can change how the gradient looks like by adding or removing stops, adjusting their position, and setting the color and transparency of each.

    • To add a color stop, click below the gradient slider.
    • To remove a color stop, drag and drop it outside the Gradients palette.
    • To reverse color stops, click Reverse next to the Gradient color well in the Tool Options pane.

  5. Click any of the color stops to fine-tune its color using the Colors window.

Tip: If you're looking to create a transparent or semi-transparent color stop, in the Colors window, select any color and drag the Opacity slider to the preferred opacity.

Manage gradient swatches

Add: To add a gradient you've created as a swatch to use in the future, click Add in the gradients palette.

Remove: To remove a gradient swatch, Control ⌃–click it and choose Remove.

Redefine: To redefine an existing gradient with new colors or color distribution, Control ⌃–click the gradient swatch, and choose Redefine.

Import: Drag a .gradients file from anywhere on your Mac to the Pixelmator Pro icon in the Dock, or directly to the Gradients palette.

Export a single swatch: Drag the color swatch from the Gradients palette onto your desktop or any other folder on your Mac. You can also Control ⌃–click the gradient swatch and choose Export.

Export all swatches: Control ⌃–click just next to any color swatch and choose Export.

Pixelmator Pro User Guide