Search Results

Resize, rotate, and flip layers

You can use the Arrange tool to change the size of image or shape layers in your image, either freely or proportionally, or set specific dimensions in a number of different units. You can also rotate or flip image, shape, and text layers.

Resize a layer
  1. Choose the Arrange tool by doing one of the following:
    • Click in the Tools sidebar.
    • Choose Tools > Arrange (from the Tools menu at the top of your screen).
    • Press the V key on your keyboard.
  2. Select a layer or layer group.
  3. To choose whether to resize a layer freely or proportionally, select or deselect "Constrain proportions" in the Tool Options pane.
  4. Do one of the following:

    • Resize manually: Drag any of the layer handles (white squares around the layer).
      Tip: To see the size information when resizing layers, make sure information labels are turned on in the Pixelmator Pro preferences.
    • Resize to specific dimensions: In the Tool Options pane, enter the size you need in the Width and Height fields.

    To change the units, click the Size pop-up menu and choose a new unit. You can also enter dimensions together with the units, for example, "2 in" or "4 cm".

Note: If a layer happens to be larger than the canvas, the layer handles may show up beyond the edges of the canvas. To resize such layers, you'll need to zoom out of the image until you see the layer handles.

Rotate a layer
  1. Choose the Arrange tool by doing one of the following:
    • Click in the Tools sidebar.
    • Choose Tools > Arrange (from the Tools menu at the top of your screen).
    • Press the V key on your keyboard.
  2. Select a layer or layer group.
  3. In the Tool Options pane, drag the Rotate wheel, or enter a specific angle in the Angle field to rotate the layer.

Tip: You can also press and hold the Command ⌘ key, then drag one of the layer handles to rotate.

Flip an image or shape layer
  1. Choose the Arrange tool by doing one of the following:
    • Click in the Tools sidebar.
    • Choose Tools > Arrange (from the Tools menu at the top of your screen).
    • Press the V key on your keyboard.
  2. Select a layer or layer group.
  3. Do one of the following:

    • Choose Arrange > Flip Horizontally or Arrange > Flip Vertically (from the Arrange menu at the top of your screen).
    • In the Tool Options pane, click to flip the layer vertically, or to flip it horizontally.

Update the orientation of a shape

When you rotate a shape, Pixelmator Pro remembers its original orientation. As a result, whenever you flip a rotated shape, it is flipped according to the original, rather than the new orientation. To update the orientation of shape, you can reset its layer handles.

  1. Choose the Arrange tool by doing one of the following:
    • Click in the Tools sidebar.
    • Choose Tools > Arrange (from the Tools menu at the top of your screen).
    • Press the V key on your keyboard.
  2. Select a shape layer.
  3. Choose Format > Shapes > Reset Shape Handles.

Pixelmator Pro User Guide