Search Results

Create an empty image

To start working on a new, empty image in Pixelmator Pro, you first choose a size for the image. You can choose from one of the pre-made templates in the template chooser, create an empty image with a custom size, or create an image from the Clipboard.

Create an image from a template
  1. To open Pixelmator Pro, click the Pixelmator Pro icon in the Dock, Launchpad, or the Applications folder.
  2. Do one of the following:

    • In the Pixelmator Pro welcome screen (shown below), click "Create an empty new document".

    If the Welcome screen doesn't show up, choose Window > Welcome to Pixelmator Pro (from the Window menu at the top of the screen). You can also press Command ⌘ + Shift ⇧ + 1 on your keyboard.

  • Choose File > New (from the File menu at the top of your screen).
  • Control ⌃–click the Pixelmator Pro icon in the Dock and choose New.
  1. In the template chooser, scroll to find the image size you need, then double-click the template to open it.
  2. Click OK or press the Return ↵ key.

If you want, you can create a custom template and save it to My Templates in the template chooser.

To create a custom template:

  1. In Pixelmator Pro, choose File > New (from the File menu at the top of your screen).
  2. In the template chooser, enter your new template dimensions and click OK to create a new document.
  3. Choose File > Save as Template (from the File menu at the top of your screen), name your template, and click OK.

If you don’t want to keep the new template, Control ⌃-click it in the template chooser and choose Delete. You can’t delete templates that came with Pixelmator Pro.

Create an image with a custom size
  1. To open Pixelmator Pro, click the Pixelmator Pro icon in the Dock, Launchpad, or the Applications folder.
  2. Do one of the following:
    • In the Pixelmator Pro welcome screen (shown below), click Create an empty new document. If the Welcome screen doesn't show up, choose Window > Welcome to Pixelmator Pro (from the Window menu at the top of the screen.)
    • Choose File > New (from the File menu at the top of your screen).
    • Control ⌃–click the Pixelmator Pro icon in the Dock and choose New.
  3. In the template chooser, click Show Details.

  4. Choose the measurement units, resolution, and color depth from the pop-up menus.

  5. Enter the width, height, and resolution of the image.
  6. Click OK or press the Return ↵ key.
Create an image from the clipboard
  1. To open Pixelmator Pro, click the Pixelmator Pro icon in the Dock, Launchpad, or the Applications folder.

  2. Do one of the following:

    • In the Pixelmator Pro welcome screen (shown below), click Create an empty new document. If the Welcome screen doesn't show up, choose Window > Welcome to Pixelmator Pro (from the Window menu at the top of the screen.)
    • Choose File > New (from the File menu at the top of your screen).
    • Control ⌃–click the Pixelmator Pro icon in the Dock and choose New From Clipboard.
  3. In the template chooser, choose the Clipboard option.
  4. Click OK or press the Return ↵ key.

    The new image will be created using the image you have saved to the clipboard. The clipboard is a macOS feature that contains the last thing you copied on your Mac — if it’s an image, the clipboard option will appear in the template chooser. If it's text or something else, that option will not be shown.

Pixelmator Pro User Guide