Search Results

Working with layer styles

When working with layer styles, there are a couple useful things to know that will let you maximize your results. For example, you can rearrange the order in which styles are applied, temporarily disable specific styles, or even reset all the styles applied to a particular layer.

Temporarily turn off a single style

When a layer style is turned off, it no longer shows on the layer but is still visible in the Tool Options pane. Turning the layer style back on restores all of its previous settings.

  1. Choose the Style tool by doing one of the following:
    • Click in the Tools sidebar.
    • Choose Tools > Style (from the Tools menu at the top of your screen).
    • Press the S key on your keyboard.
  2. Select the layer or layers you would like to edit.
  3. Click the checkmark next to the style you’d like to turn off.

Remove a style

When you remove a layer style, it no longer shows on the layer, is no longer visible in the Tool Options pane, and adding the style again from the Add menu uses default style settings.

  1. Choose the Style tool by doing one of the following:
    • Click in the Tools sidebar.
    • Choose Tools > Style (from the Tools menu at the top of your screen).
    • Press the S key on your keyboard.
  2. Select the layer or layers you would like to edit.
  3. Click the name of the effect you’d like to remove to reveal a pop-up menu and choose Remove Style.

Copy a layer style from one a layer to another

A quick way to apply the same layer style to multiple layers is by using layer style presets. However, you can also apply the same layer style to multiple layers by simply copying it over.

  1. Select the layer with the style you’d like to copy.
  2. To copy the style, do one of the following:
    • Choose Format > Styles > Copy Styles (from the Format menu at the top of your screen).
    • In the Layers sidebar, Control ⌃–click the layer from which you’d like to copy a style and choose Styles > Copy Styles.
  3. Select the layer to which you’d like to apply the copied style.
  4. To paste the style, do one of the following:
    • Choose Format > Styles > Paste Styles (from the Format menu at the top of your screen).
    • In the Layers sidebar, Control ⌃–click the layer to which you’d like to paste the style and choose Styles > Paste Styles.
Rearrange the order of layer styles

If you apply two or more of the same layer style to a single layer, you can rearrange the order in which they are applied.

  • Click the name of the style you’d like to arrange and choose one of the following:

    • Send Forward: Sends the layer style forward in the style stack.
    • Send to Front: Sends the style to the top of style stack.
    • Send Backward: Sends the style backward in the style stack.
    • Send to Back: Sends the style to the bottom of the style stack.

Flatten layer styles

Flattening (or merging) all the styles applied to a layer can be useful when you want to make edits to the layer together with the layer style. For example, you might want to erase part of a layer as well as the shadow applied to it. Without flattening, the shadow would adapt to the new shape of the layer.

  1. Choose the Style tool by doing one of the following:
    • Click in the Tools sidebar.
    • Choose Tools > Style (from the Tools menu at the top of your screen).
    • Press the S key on your keyboard.
  2. Select the layer or layers you would like to edit.
  3. Hold down the Option ⌥ key and, in the Tool Options pane, click the Flatten Styles button at the bottom. You can also choose Format > Styles > Flatten Styles (from the Format menu at the top of your screen), or in the Layers sidebar, Control ⌃–click the layer you’d like to flatten and choose Styles > Flatten Styles.

Pixelmator Pro User Guide