Search Results

Select layers

When working on an image with multiple layers, you need to make sure to select the one you’d like to edit. For example, when applying effects, adjustments, retouching a layer, or doing just about anything else, most of the time, the tools will affect just your active layer.

When using certain tools, such as the Arrange, Style, and Type tools, you can also select multiple layers and the changes you make will affect every selected layer.

Select a single layer in a composition

You can select a layer from the Layers sidebar or by simply clicking it on the canvas.

  • To select a layer using the Layers sidebar, find it in the list of layers and click to select it. Choose View > Layers > Show Layers or press Option ⌥ + L if the Layers sidebar isn’t visible.

  • To select a layer directly in your image, first select the Arrange tool (choose Tools > Arrange or press the V key on your keyboard), then click a layer to select it.

If you're unable to select a layer directly in your image, make sure the automatic layer selection is turned on.

Select multiple layers in a composition
  • Select multiple contiguous layers: In the Layers sidebar, click any layer to select it (choose View > Layers > Show Layers if the Layers sidebar isn’t visible), then Shift ⇧-click any other layer. Every layer in between those two layers will also be selected.

  • Select multiple noncontiguous layers: In the Layers sidebar, click any layer to select it (choose View > Layers > Show Layers if the Layers sidebar isn’t visible), then Command ⌘-click any other layers you’d like to select.

  • Select multiple layers directly in your image: Select the Arrange tool (choose Tools > Arrange or press the V key on your keyboard), then click a layer to select it and Command ⌘-click any other layers you’d like to select.

  • Drag-select multiple layers: Select the Arrange tool (choose Tools > Arrange or press the V key on your keyboard) and make sure Auto Select is turned on. Then, click and drag over the layers you’d like to select.

Select all layers

To select all the layers in the Layers sidebar.

  1. Choose the Arrange tool by doing one of the following:
    • Click in the Tools sidebar.
    • Choose Tools > Arrange (from the Tools menu at the top of your screen).
    • Press V on your keyboard.
  2. Choose View > Layers > Show Layers or press Option ⌥ + L if the Layers sidebar isn’t visible.
  3. Press Option ⌥ + Command ⌘ + A on your keyboard to select all layers.
Select a layer in a group

Some layers in your document may be grouped. When you select a layer group, all the layers within that group are automatically selected. To select the individual layers in a group, you need to expand it first.

  1. In the Layers sidebar, click the disclosure triangle next to the group layer (choose View > Layers > Show Layers or press Option ⌥ + L if the Layers sidebar isn’t visible).

  2. Click a layer to select it.

Turn automatic layer selection on or off

Whenever you use the Arrange tool to click or drag on the canvas, the uppermost layer is automatically selected and edited. However, it is sometimes useful to turn off automatic layer selection so you can, for example, move a layer below another layer directly on the canvas without selecting the upper layer.

To turn automatic layer selection on or off:

  1. Choose the Arrange tool by doing one of the following:

    • Click in the Tools sidebar.
    • Choose Tools > Arrange (from the Tools menu at the top of your screen).
    • Press V on your keyboard.
  2. Control ⌃-click anywhere in the image and choose Auto Select from the shortcut menu. Alternatively, scroll to the bottom of the Tool Options pane and select or deselect Auto Select there.

Pixelmator Pro User Guide