Can’t load pictures from the photo roll

Discuss Pixelmator for iOS and mobile image editing.
User avatar

2019-02-12 14:04:26

Trying to load pictures from my photo roll on my iPad Pro 11”. I’m on version 2.4.4.
User avatar

2019-02-13 16:23:49

Open Pixelmator and create a new document by clicking the + in the upper left corner. Select Photos.

If you want to import a photo from your camera roll into an existing document open the document and click the + in the upper right hand corner. Select Camera Roll.
User avatar

2019-03-03 14:38:51

I have tried to create a new document by opening a photo from “Photos” and by taking a new photo while inside Pixelmator. Every time, I get the error message “Unable to Open Image - an error occurred while opening the image”. I am using Pixelmator version 2.4.4., on an iPad Pro 11” running iOS 12.1.4.

I have given Pixelmator access to my photos and my camera. I have tried to reinstall Pixelmator, which hasn’t resolved the issue.

I do not have any problems with Pixelmator on my iPhone XS Max.
User avatar

2019-03-04 16:28:08

Hey there, could you email us about this at Thanks in advance!
User avatar

2019-06-07 20:30:16

Peter, I’ve got a similar situation with a 9.7 iPad Pro. I can import screen shots but not actual photos consistently. I just get a “Unable to Import Image - The image cannot be imported” message. I’ve been in touch with Support, even sent a requested video of the issue today, but they haven’t come up with any solutions yet.