slow and latency on every taks in High Sierra

Chat about the original Pixelmator.
User avatar

2017-12-29 10:45:17

Does anyone else has this problem with Pixelmator 3.7, I am running in High Sierra, for every tasks, it's a delayed for a few seconds, my iMac is 27in with 24GB RAM?

It is just unworkable right now to even use it!
User avatar

2018-02-06 17:57:27

Same here. Making it very difficult to work on this project!
User avatar

2018-02-07 06:34:11

If you ever start getting any show-stopping issues like this, please let us know at support@pixelmator.com — sometimes, there may be a bug with Pixelmator, other times (surprisingly often), people inadvertently create overly large images by bumping the PPI up over 300. If that's the case, the fix is pretty simple.
User avatar

2018-08-06 23:54:42

I'm having this same problem on a 2017 Macbook (running 10.13.3 — I can't update it to 10.13.5), but not on a 2014 iMac (running 10.13.5).

It was temporarily fixed (somehow) with Pixelmator 2.7.3, but the problem has occurred again.

Whenever Pixelmator is slow, the "pkd" process goes crazy on my laptop and uses "400%" of CPU.
User avatar

2018-08-07 00:01:44

Ok, this is weird. It's reproducible 100% of the time if I drag a PNG image (any PNG at all) to the application icon and try to edit it.

But if I make a new pixelmator document (not in PNG form) and then open the PNG, it edits just fine.

Could this issue be somehow PNG specific? Or is it something about the Apple access sandbox thing? Like maybe the file is getting constantly queried to see if Pixelmator has access to it?
User avatar

2018-08-07 09:47:38

From that description, it's difficult to say exactly what could be going wrong, but we'd love a few more details about this — would you be able to email us at support@pixelmator.com?