Can't get eraser tool to work

Chat about the original Pixelmator.
User avatar

2017-11-04 23:46:42

I opened a jpg and wanted to erase part of it by hand. It is automatically set as the background layer. I can't get the eraser tool to do anything. What am I missing?
User avatar

2017-11-05 14:49:49

Can you make a screenshot of your settings for the eraser tool and the layers palette? You can drag and drop the screenshot in the reply field of this forum to upload it. Thank you...
User avatar

2018-03-26 20:16:36

I am having the same problem.
User avatar

2018-07-05 18:34:49

So am I
User avatar

2018-07-05 18:39:42

had the brush flow set to 1, Increase and all is fine again. Having said that, I didn't change the brush setting initially so don't know why it was so low.
User avatar

2018-07-12 14:46:14

With any kind of painting/erasing issues in Pixelmator, the most important settings to check are:

1. Opacity. This can be found in the Tool Options bar. If it's at 0%, nothing will be painted.
2. Blending Mode. Also in the Tool Options bar. If you try to paint using a dark brush on a light layer with, for example, the Lighter Color blending mode, nothing will happen. Normal is the basic setting you should use if you don't need a specific blend mode.
3. Brush settings like flow. This will be in the Brushes palette. With 0% flow, nothing will be painted.

There are a few more settings that can be accidentally changed and cause issues, but those are by far the most common ones. :ok_hand:
User avatar

2020-03-21 17:28:24

I can erase jpegs added to a document, but I can't erase any part of a shape created natively in Pixelmator. Why?
User avatar

2020-03-23 05:46:22

Hi Neal.
The Eraser erases pixels from bitmap layers. If you want to use it on a shape, first turn it into pixels (right click on it in the layers panel and select Convert to Pixels or use the menu option Layer > Concert into Pixels).
Hope this helps.
- Stef.
User avatar

2021-02-14 15:40:54

My Eraser was showing as a white brush.. I lost 30 mins to this... but Go to the side panel to the layer (image) you working on and make sure its unlocked. If its unlocked Toggle it back and forth and your eraser should work again. Don't thank me, Pay me.
User avatar

2021-02-21 20:09:08

None of these suggestions worked for me. I first used the magic wand to delete a background and then tried to clean it up with the eraser tool but it won't work. No clue why. :(
User avatar

2021-02-25 15:32:10

My guess is – the selection you made with the Magic Wand tool is still active, which means unselected areas can't be edited. Try pressing the Command-D keyboard shortcut to clear your selection before trying to erase areas. If that doesn't help, shoot us an email at and we'll dig deeper!
User avatar

2023-01-18 03:18:17

Just wanted summarize having read this thread and still had to tinker

1) If you have anything selected, you can only erase within the selection.
2) set the brush opacity to 100% to fully erase and decrease from there. (setting it to 30-50% is a good way to blend transitions,)
3) Objects like shapes or text can't be erased until converted to pixels
4) Obviously need to have the layer selected that you want to erase pixels.
5) and yes, said layer needs to be unlocked

Thanks everyone for the posts above... they helped me finally figure this out!
User avatar

2023-01-24 15:34:17

This is probably a weird way to fix the eraser not working but what I do is click "Add Mask" (under Layers) and then immediately click "Remove Mask" and that usually does the trick for me. I have no idea why this works but it does.