Can't open Raw files in Catalina using Pixelmator

Is something not working like it should? Let us know.
User avatar

2020-08-05 07:19:42

I upgraded my MBP to Catalina using dosdudes patch some time ago. Today I discovered that I can no longer open Canon raw files. It shows a black image with some coloured dots. Has anybody else had this same experience?
Should I downgrade to High Sierra? Or is there another fix? (other imaging software still works correctly: Affinity Photo, Fastrawviewer etc)
User avatar

2020-08-11 12:46:09

If I've understood correctly, you've used the patch to upgrade to Catalina on an unsupported device? If so, the most likely reason you're seeing these issues in Pixelmator is that we rely on the native RAW processing engine in macOS and it's likely that the GPU not being natively supported in Catalina is the culprit here. For that reason, downgrading to High Sierra could well be the only viable fix...

Just out of interest, are you able to open those RAW photos in the Photos app itself?
User avatar

2020-08-12 12:58:14

Hi Andrius,

thanks for your reply. You understand it correctly.
I never use Tried it today and the same result as Pixelmator.
So thanks for the suggestion. I will consider downgrading.

User avatar

2020-08-13 17:54:15

Ok, downgrading did the trick. Pity. All other apps worked fine with the Catalina updater patch.
However, thanks for Pixelmator. Keep up the good work!