Pixelmator Classic won't launch

Is something not working like it should? Let us know.
User avatar

2020-04-23 17:51:15

A few minutes ago, I tried to open a JPEG I'd downloaded from Google Image Search in Pixelmator, to resize it. Pixelmator crashed, and since then, it refuses to finish launching.

Specifically: When I click the Pixelmator icon in my dock, the icon jumps a couple of time, and the white dot appears next to it, but then it stops jumping and the dot vanishes. The dialog that normally shows, asking if I want to create a new image or open an existing one, never appears.

I've already tried rebooting my Mac, and then deleting and reinstalling Pixelmator through the App Store. Still won't launch.

I am also a user of Pixelmator Pro, which is working fine. But I like having both programs available.

I've got a Mac mini (late 2014) with 8 GB of RAM, a 2 TB hard drive with 1 TB of free space available, and I'm running MacOS Mojave 10.14.6.
User avatar

2020-04-23 18:20:57

Following up: Just now, nearly half an hour after the last time I tried to launch the application, the system dialog for reporting an application crash to Apple appeared.
User avatar

2020-04-24 13:52:29

Hi Avram, it sounds like maybe a file is being restored that cannot be opened — could you find the crash report and send it to us at support@pixelmator.com? You'll find the steps for that here:

https://pixelmator.freshdesk.com/suppor ... ash-report

In the meantime, when opening the app, could you also try Shift-clicking the app icon in the Dock to prevent it from attempting to restore any windows?
User avatar

2020-04-25 22:08:00

Shift-clicking doesn't seem to help.

I think Apple may have changed the interface on Console since that page was made; I don't see a Crash Reports item in the sidebar, but there's a folder labeled "User Reports" full of files that end in ".crash" and look like crash reports. Weirdly, while I see a bunch of crash reports from Apr 23rd, I see none from today, despite having just now tried to launch the app again a few times (both with and without the Shift key). I'll send in the most recent one.
User avatar

2020-04-26 14:14:29

Thanks, we'll take a look! If you'd like, you can also try resetting the app to default, I have a feeling that should help. The instructions for that are available here:

https://pixelmator.freshdesk.com/suppor ... pixelmator
User avatar

2020-04-26 15:22:25

OK, moving the prefs folders to the Desktop seems to have worked. Yay, thanks!
User avatar

2020-04-27 08:58:47

Sweet, I'm glad to hear it!
User avatar

2020-06-09 06:25:54

avram, where is the prefs folders? I'm stuck at a similar issue - it is stuck at startup trying to open a previously opened file.
User avatar

2020-06-09 07:03:53

Ok, I moved the plist file. And also had to restart the machine to make it work.