Opening pre-Catalina image files in Pixelmator 3.9

Is something not working like it should? Let us know.
User avatar

2019-12-05 20:03:39

I am having a problem opening files that may have been created with my older (pre-Catalina) Pixelmator.

Nor can I find Support for 3.9 Classic; we are rolled straight into Support for Pro. Which I have tried and do not like... planing to stay with Classic.

Has anyone else had a similar problem? Any workaround ideas?
User avatar

2019-12-05 20:39:18

Hi there, what kind of problems are you having? The original Pixelmator is still supported and our main support channel for all our apps is the email address. I can also try and help out here (if you let me know a little more about the issue you’re having).
User avatar

2019-12-05 21:21:12

Thanks, Andrius. Getting a quote from the error message now...

The document “filename.pdf” could not be opened. got the same for all the .pxm files I tried.

Sorry I can't be any more specific.
User avatar

2019-12-05 22:17:12

If you haven’t done so yet, could you try restarting your Mac and let me know if that helps at all?
User avatar

2019-12-09 16:28:33

Dear Andrius.

Thank you for that tip. I have tried a variety of.pdf and .pxm files and all seem to pop open just as they were intended. Did something change somewhere along the way?

Any information about what may have caused this issue, how widespread it is or was, and how it got fixed, would be of interest--provided I can understand t.

Thanks, again.

User avatar

2019-12-10 08:24:01

Sometimes, a good ol' restart can fix a variety of seemingly pesky issues. This can sometimes happen when opening a large number of images in succession without quitting Pixelmator, resulting in a lack of available memory. Usually quitting and reopening Pixelmator is enough, but I suggested a restart for good measure.
User avatar

2019-12-10 22:43:56

UPDATE: It must be a bug with the new Mac iOS update. After restarting my computer a handful of times, the files are now opening.

I have restarted my computer and restarted Pixelmator and it is still not allowing me to open PXM files or JPG files. It just keeps saying that the file cannot be opened.