Pixelmator reliably hangs with CPU at 90% after exporting slices

Is something not working like it should? Let us know.
User avatar

2019-08-19 01:45:26

The following sequence always produces the following outcome:
- Any image; in my case, images are always 1440 square
- 5 guides (2 vertical, 3 horizontal)
- Use slice tool to create 6 slices, each 480 square, all adjoining / touching each other
- "Export for web" permits me to successfully export the slices. (The dialogs work, dialog windows properly go away, slices properly exported to disc). It does not matter where on disc the slice files are placed (e.g. Desktop, a Dropbox or Google or iCloud folder, etc.)

At this point, the Pixelmator app "hangs" at high CPU. This means:
- Cursor remains in the "slice" cursor (where it was when the export was done)
- The Pixelmator app is fully unresponsive. No keyboard shortcuts work in Pixelmator, cursor moves, but does not affect any Pixelmator window or floating palette.
- MacOS Activity Monitor app shows Pixelmator CPU usage spiking up near 90-100%. (Of course, since this is a multi-core machine, we're only maxing out 1 core, and the machine remains usable).
- The only way out is to "Force Quit" the application
- On restart, Pixelmator acts properly. If one had saved their work prior to Force Quit, all work is preserved.

This has been reliably reproducible for months.
Environment:
- MacOS 10.14.6 (Mojave)
- MacBook Pro (13-inch, 2017, Four Thunderbolt 3 Ports)
- Pixelmator 3.8.5

Does anybody else see this? Is this known, or should I get in touch with Pixelmator support?