You don't have permission.....

Is something not working like it should? Let us know.
User avatar

2020-12-16 21:28:59

I have Pixelmator 3.9.2. now running OS 10.15.7.

Most of my work involves files on chips from cameras. Since updating to Catalina, I have the following problem.

While editing a file, the message pops up:

This document could not be autosaved. You don’t have permission…..

If I try to Revert Changes, I get: You don’t have permission to save the file …

The same message comes up if I try to just Save.

I also sometimes get the Pixelmator dialogue box saying:

The operation couldn't be completed.
(PTImageIOErrorDomain error 2000).

But Get Info for the chips say: You have custom access.

And Sharing and permissions for the files I'm trying to save or revert always says: You can Read and Write.


Thanks,
David
User avatar

2020-12-18 16:46:33

Hey David, could you email us about this at support@pixelmator.com? We'll take a closer look at what could be going wrong.
User avatar

2021-04-05 13:52:43

I have been experiencing the same problem. I can save once, but if I leave the app open and come back later it says "You don't own the file...you don't have permission to write to it.
User avatar

2021-04-07 07:20:01

by Anne Gassel 2021-04-05 10:52:43 I have been experiencing the same problem. I can save once, but if I leave the app open and come back later it says "You don't own the file...you don't have permission to write to it.
Hey Anne, are you to reproduce this consistently? If you haven't done so already, perhaps restarting your Mac would work here.
User avatar

2021-04-29 12:00:38

I am experiencing this same issue. I am running Catalina 3.9.2.
User avatar

2021-05-04 13:27:49

I am having the same exact problem on two different Macs. One is running Catalina and the other is Mojave. It happens in Pixelmator but most often in Pixelmator Pro. The one solution I have found that consistently works is leaving the file that's giving me trouble open in Pixelmator, going to Finder to the folder ~/Library/Containers/com.pixelmatorteam.pixelmator.x/Data/Library/Autosave Information, and then changing all of the permissions for all of the folders/files in that folder to make sure that my account has read and write access.

I've also recently begun running in to this error in Pixelmator Pro: "The document “...” could not be saved." It seems to pop up when I'm editing/saving a file to Google Drive. I then have to duplicate it, save it to my Macintosh HD, and then delete the other copy that was trying to save on Google Drive. Then, I can manually move the file in the Finder over to my Google Drive folder.

Both of these issues are maddening...