cannot paste shape

Chat about the original Pixelmator.
User avatar

2017-12-31 07:51:37

I'm following a tutorial where I convert text into a shape. Then I can select each letter to reshape it. Then I need to copy the individual letter and paste it as a new layer.

No matter what I do I cannot get the letter to paste. When I use command C it say copy but when I use command V it does not paste or when I choose paste from the menu it does not paste.

How on earth can I get it to paste?

The tutorial is here - ... -as-shape/

Version 3.7 Mount Whitney (71005)

Thank you !
User avatar

2018-02-25 02:41:57

I've been having the same problem using macOS. My image has quite a number of layers and shapes now and I can copy a shape once into a layer (so there are 2) but no more than that. Paste doesn't do anything after there are 2 shapes in a layer. It's getting impossible to use Pixelmator for this image now as I'm having to create lots more layers rather than having a number of shapes in a single layer that I can turn on and off as needed.

Is there some limit to the maximum number of elements in a Pixelmator image that could be causing this?

User avatar

2018-02-25 18:26:45

@stephen I'm not sure what is happening with you. Hopefully you sorted it.

@dteirney This bit's not that intuitive:
Cut or copy a shape to the clipboard.
With the move tool (V), select the layer with two shapes in it.
Then select one of the shapes by double-clicking on it.
Now that you have one of the shapes in the layer selected, you can paste additional shapes.
Note that multiple shapes on one layer will react differently to multiple shapes on multiple layers, e.g. if you add a stroke to two shapes that overlap on the same layer, the outline will be drawn around the union of the two shapes. This can be very useful as long as it doesn't catch you out.
User avatar

2018-02-25 20:56:01

Thanks for the advice. That's exactly what I'm doing. Selecting one of the shapes by double-clicking. Ctrl-C then I try to Ctrl-V but nothing happens. Even tried using the menu item equivalents but that didn't work either. I've been using Pixelmator since it was originally released and it's only stopped working in this diagram recently.

I'm assuming it's due to the number of layer or shapes within all the layers or something else entirely.

I can share the image if anyone wants to debug what's going on. Diagram with house extension plans.

User avatar

2018-02-25 21:07:12

Am happy to help debug if you can upload the file somewhere. Will check in on this forum periodically.
User avatar

2018-05-10 10:52:31

I've been trying to ignore this problem because it happens on any image I create. I thought it was only the quite large one. However, after creating a new image and adding a Shape, copying and pasting fails as soon as there are 2 shapes in the same layer.

I have noticed that each time I press Ctrl-V I get an Error from Pixelmator showing up in the Console application log.

Nothing really useful to show though since the detail is <private>

error 22:49:04.792978 +1200 Pixelmator <private>
User avatar

2018-05-10 10:58:32

I have been able to narrow down the case where I'm having problems.

If I add a shape and then copy it, I can paste it many times into the layer.

However, as soon as I select a single shape (by double-clicking on it) within the layer, I can no longer paste a copy of that shape if there is already more than 2 shapes in the layer.
User avatar

2018-07-03 02:51:33

I'm having the same problem here using Pixelmator on macOS. As far as I can remember the last 3 versions of Pixelmator introduced this Bug that greatly disrupts the use of Pixelmator. Command-X Command-V with shapes always worked perfectly in the past, but now we have this problem that is taking a lot to be solved.