pixelmator pro using significant energy (DESPITE app not running and not been run in ~72 hours)

Is something not working like it should? Let us know.
User avatar

2021-04-13 14:17:46

Hi,

macos claims pixelmator pro is using significant energy (DESPITE app not running and not been run in ~72 hours)

is this a bug in OSX or are the Extensions so energy hungry?



Image



Image
User avatar

2021-04-13 15:34:50

Processes do sometimes "run away"
if you feel comfortable with the terminal program, you can see what pixelmator might be doing. On my iMac now:
Looking for pixelmator....
% /bin/ps -awxouser,pid,ppid,pcpu,stime,nice,time,command | grep -i pixelmator
user 10167 1 0.0 0:01.21 0 0:05.25 /Applications/Pixelmator...MacOS/ThumbnailExtension
user 62044 1 0.0 0:01.03 0 0:04.14 /Volumes/Current/Applications/...MacOS/Pixelmator Pro
user 62208 677 0.0 0:00.00 0 0:00.00 grep -i pixelmator
% kill 10167 62044
looking again for confirmation...
% /bin/ps -awxouser,pid,ppid,pcpu,stime,nice,time,command | grep -i pixelmator
user 10167 1 0.0 0:01.21 0 0:05.25 /Applications/Pixelmator.../MacOS/ThumbnailExtension
user 62242 677 0.6 0:00.00 0 0:00.00 grep -i pixelmator
hhhmmm Extension did not die, force kill it.
% kill -9 10167
% /bin/ps -awxouser,pid,ppid,pcpu,stime,nice,time,command | grep -i pixelmator
user 62266 677 0.0 0:00.00 0 0:00.00 grep -i pixelmator
Now it's gone, and when I restarted PP the extension did not start

It restarted when I did a quicklook on the pxd in Finder. and the extension remained when I quit PP, had to kill it again.
User avatar

2021-04-13 15:42:42

This is a bit more concise terminal command:
/bin/ps -awxouser,pid,command | grep -i pixelmator
user 63284 /Volumes/Current/Applications/Pixelmator Pro.app/Contents/MacOS/Pixelmator Pro
user 63342 grep -i pixelmator