Text tool - Line of height dont work !

Is something not working like it should? Let us know.
User avatar

2019-08-26 15:20:18

When i try to move the slider, nothing happening...
I tryed many variations of creating and selecting the textbox, but always the same ...
(in case of new project, the problem is still present)
User avatar

2019-08-26 15:28:54

Line height is not the height of the text, per se.
It is height between lines of text;

normal text
next line

Text height change

Next line
User avatar

2019-08-27 18:33:56

It is height between lines of text - YES, i know .. but that is not working.
it was good a few days ago, i worked with it, but now i do anything no effect.
is it possible to reset the user settings? or some other trick?
User avatar

2019-08-27 19:39:58

Hi Varjubacsi.
There isn’t (or at least shouldn’t) be a trick to it. I’ve just checked to make sure it works as expected. It still does for me. (PixPro 1.4.1 on macOS 10.14.6).
* If there’s nothing selected in the textbook then nothing happens.
* If a line (or part of a line) is selected then the line height for that line is altered.
* If all of the text in the text box is selected or the text box selected as an object then all lines are changed together.
If the above isn’t working (and I’m guessing it’s not) then I think you have found a bug that exists only with a specific image or specific configuration. I’d recommend trying out a few scenarios as well as opening (copies of) previous images you have created that have text in them. support@pixelmator.com should be able to help further.
User avatar

2019-08-28 18:08:22

thank you!
Yes, since this was broken before and worked on the update, it will be a special bug ...
User avatar

2019-09-05 18:32:15

The problem is solved, all settings had to be reset
But I'm afraid you'll never find out how it came about.
User avatar

2020-02-01 03:02:07

I know I'm responding to an old forum post but if anyone's running into this bug where the line height dragger doesn't actually change the line height for whatever reason, I think I figured out what happened while talking to Pixelmator Support.

Turns out that if you ever pasted content from a website into a text box, it's possible that the web formatting will be embedded with your text, and cause Pixelmator to be confused. In this case, select the text in the text box that's misbehaving and then select one of the text presets such as 'Body' to the text. It should reset the formatting and you should be able to go from there.
User avatar

2021-05-29 18:42:35

Thank you, Matthew Widjaja! That did it for me.