Error when trying to update to version 1.4.1 with iMac (27 inches, end of 2013)

Is something not working like it should? Let us know.
User avatar

2019-08-22 19:04:23

I use an iMac (27 inches, late 2013) to do design work with the Pixelmator Pro application (version 1.4). This iMac has the graphic Nvidia GeForce GTX 780M 4GB and I am testing the latest beta of macOS Catalaina (10.15 19A536g).

When I try to update Pixelmator Pro to the latest version (1.4.1) I get an error that tells me: "Pixelmator Pro is incompatible with the graphics card of this computer"

I would like to know if my mac is going to be incompatible with future Pixelmator Pro updates, or is it a bug?
User avatar

2019-08-23 13:12:12

I have been getting the same error message on my iMac (21.5-inch, Late 2013) as well when trying to update. Mine has a NVIDIA Geforce GT 750M 1 GB. I am also running the latest macOS Catalina 10.15 (19A536g).

Thank You
User avatar

2019-08-27 16:17:57

This is a known issue that we've reported to Apple — it's on its way to being fixed but, if you haven't done so already, could you also shoot us an email about this at support@pixelmator.com with your Apple IDs? Thanks!