Portrait Editing does not fill background.

Is something not working like it should? Let us know.
User avatar

2019-02-16 12:51:03

It seemed to work as the video said it should. However: I dragged in another picture, moved it down in the Layer window, and shift-clicked on the silhouette (2nd) of the Portrait image. Yes, it went behind, as it should, but it did not fill the background, even though both were 3024 × 4032! Even if not, it should adjust IMHO.



In fact, it seems that it did not even match the upper left corners, as the background fill only is getting the bottom third part of the layer (and almost all of the width)



Something is amiss here. That background shot is missing most all of the original picture. And, they are not .JPEGs, but .HEIC extensions.



Image
User avatar

2019-02-18 09:35:29

Would you be able to share that Pixelmator Pro document with us at support@pixelmator.com and if possible, the original files as well? It does look like something might be amiss, but it's a little difficult to tell just from the screenshot. Thanks in advance!
User avatar

2019-02-18 21:11:31

I will do that this evening. However, a couple of points: Everything I use to transfer from the 8P to the MBP say the Portrait mode pictures are .JPEG (iPhoto, Photos, Image Capture, iMazing), and Pixelmator Pro even shows the file name as .JPEG

And, I cannot upload a 1.6MB .HEIC file to this post?

It spins and spins but does not insert the [img] tag.
Post takes a long time at the address bar, but finally does come back w/o the image.
User avatar

2019-02-19 11:21:35

HEIC images are currently not supported on the web in general, so I would guess that's why they aren't uploading. Also, JPEG files can (and do) also have embedded masks, so that shouldn't be an issue either.
User avatar

2019-02-19 17:09:14

Yes, but the image I uploaded are both the same size, yet the overlay wasn't.
User avatar

2019-02-22 13:28:45

Understood, if you haven't done so already, would you be able to send us a quick email about this at the support@pixelmator.com address?