Eyedropper in Apple Colors Palette makes mouse pointer disappear

Is something not working like it should? Let us know.
User avatar

2018-06-01 16:46:54

(Pixelmator Pro 1.1 Monsoon on macOS 10.13.4 High Sierra on MacBook (Retina, 12-inch, Early 2015))

To reproduce:
1. Open a new file
2. Select the Paint* tool.
3. Click on the paint color to toggle the Apple Color Palette on.
4. Click on the eyedropper at the bottom of the Apple Color Palette.
5. Click anywhere on the canvas.
Notice that the mouse pointer/brush outline/whatever has disappeared.

Workaround:
To get the mouse pointer back, move it up and left so that it is likely to be on the menu bar.
Click the mouse.
The mouse pointer is back.

I hope you can reproduce/fix. Any new release is bound to bring some bugs with it. I still think you all did a great job with 1.1 Monsoon.

- Stef.
*Color Fill, Text tool and probably anything that uses the Apple Color Palette also similarly affected.
User avatar

2018-06-04 09:44:22

Weird, I'm not seeing this bug myself — since 10.13.5 is out now, could you update and see if you can still reproduce this?

P.S. Thanks for the words of encouragement, our lead dev saw them as I was showing him the bug and I think they totally melted his heart.
User avatar

2018-06-04 10:29:00

I'm still seeing it on macOS 10.13.5 but (now that I have tried it) am also seeing it in Pixelmator, Pages, Numbers, Scapple... anywhere I can use the Apple Color Picker I am seeing the problem. I'd say that makes it look like an Apple bug not a Pixelmator Pro bug. :beetle:
Now all I have to figure out is what makes my Mac different.
User avatar

2018-06-04 21:27:18

I had the same thing happening on the latest MacOS version but with totally different apps. Pixelmator Pro wasn't running. So I'm pretty sure this is a MacOS issue and not Pixelmator related.
User avatar

2018-06-05 06:39:29

Hi Sebastiaan.

It's good to know I'm not alone. Can you let me know if you find a fix? In return, I'll post here if I find anything.

I'm not using any custom color pickers and my ~/Library/ColorPickers and Macintosh HD/Library/ColorPickers directories are empty.

- Stef.