Crazy Memory Leaks – Magically Using 100+ GB of RAM

Is something not working like it should? Let us know.
User avatar

2018-09-14 02:15:39

Formatting got a little funky once I included the pics. Sorry for all the white space.

Hey there! I just got Pixelmator Pro after using the original for nearly a decade.

If I'm doing anything other than idling on a blank document, Pixelmator Pro will spike memory consumption after a few minutes. We're talking a steady and gradual increase from 200-400 MB of RAM usage to 100+ GB of RAM usage. It usually completely freezes my computer, requiring a hard reboot with the power button, once it reaches 125 GB. I'm assuming that's my personal or my system's virtual memory limit.

Timeframe
This typically starts after 5-10 minutes of document editing

Instances
This is happening with newly created documents in Pixelmator Pro. The documents are simple – text, line shapes, and one of them has an image that's being masked in. So far I have seen it occur with anywhere from one to three documents open.

System Specs
13" MacBook Pro 2017
MacOS High Sierra 10.13.6 fully updated
3.1 GHz Intel Core i5
16 GB 2133 MHz LPDDR3
Intel Iris Plus Graphics 650 1536 MB

Pixelmator Pro 1.1.4

Steps to resolve
I've just deleted and re-downloaded Pixelmator Pro from the App Store so far. I can mitigate the issue by leaving Activity Monitor open and quitting before I reach 125 GB of consumed RAM, but obviously that's a bandage solution and must be done every 5-10 minutes. There's not much else I can do in the app, and once I reach critical mass the entire computer becomes a brick. I can't normally quit and I can't force quit, though that might be because of my touch bar escape button.

I need help. I know I'm going to love this new version, but I won't continue using it if I can't get this solved. Other users: Anyone run into anything similar? Pixelmator support: What can I do? I sent an email to support@pixelmator.com but didn't get an indication that it was received. No auto-reponse or anything.

Thanks!

Edit: forgot some pics

Image
Image
User avatar

2018-09-14 09:42:10

Hi there,

We got your email, but auto-acknowledgment was inadvertently turned off. It's back on now, though and we've replied!

P.S. This issue is definitely a tad unusual, so we'd really love to get to the bottom of it.
User avatar

2018-09-14 13:32:17

Thanks Andrius! I'll reply via email and report back on this thread with any resolution for other users.
User avatar

2018-09-17 08:27:37

Hey again! So, we pinned down the source of the issue — it looks like applying effects to shapes with a "0" size (completely vertical or horizontal lines, for example) would sometimes result in infinite images (because the size of the effect preview would be multiplied by 0). This wasn't happening consistently for everyone, but we've now included a fix internally and we sent you a beta version on Friday. Have you had a chance to try it out? If you have, we'd love to hear whether that version fixes this for you!