New User: Can’t Import Photos from Camera Roll

Discuss Pixelmator Photo and photo editing on iPad.
User avatar

2019-06-06 12:50:38

I just downloaded Pixelmator Photo to my 2nd-gen iPad Pro. Although I can browse my Camera Roll and Photos library, whenever I touch “+” to import a photo, I get an error message that the photo cannot be imported. All photos are iPhone photos, nothing crazy. I *can* import photos from the Browse menu that gives me access to Dropbox, etc. I just can’t import from the Camera Roll.

I’m not a newbie to photo editing, and the process seems straightforward; it’s just not working at the most basic level.

What am I missing?

User avatar

2019-06-06 19:23:18

Can you share to Pixelmator Photo from Photos using the Share extension? Either way, could you shoot us an email about this at We'll investigate!
User avatar

2019-06-07 20:53:02

Just tried: Yes, Sharing from Photos worked for images that yielded an error message when Importing directly in Pixelmator Photo.

This is a good workaround until the main issue gets sorted.

Thank you!
User avatar

2019-06-10 09:06:30

Glad to hear it! But we'd still love to get some more details about this issue at