Things changed in V2 not necessarily all for the better!

Discuss Pixelmator Photo and photo editing on iPad.
User avatar

2021-12-19 15:46:28

First of all, thanks for such an excellent image editor, at a very reasonable price. I've been using Photo for some time now, and was quite excited to see the new features in V2. However, I think there' some work to do here. All the the issues mentioned here are only since upgrading to V2, they did not occur in V1.x

As mentioned in another thread of mine, the new Filmstrip seems a bit 'buggy', with the selector sometimes jumping along to a different image than the one being worked on. It also disappears completely if you select the Edit panel, then choose another tool. This is kind of fixed by setting the Presets panel to on.

It'd be a nice idea to allow the user to be able to turn on or off the viewing of the Filmstrip.

The selection of the Crop tools didn't need 'fixing (where you select 'Crop', 'Straighten' and 'Perspective'), not sure why you had to hide this in a pop up menu.

I'd like to see the trashcan back on the toolbar too, now it's fiddly to choose the image in the Filmstrip and then select Delete (three things to click on now instead of one).

You've got the ML DeNoise hidden away in the drop down menu. Did you find the toolbar didn't have room to add it as a button there?

On the ML Denoise, is it possible to have some kind of user fine tuning? Or perhaps a more basic/manual DeNoise adjustment. I'm finding this can either have almost no effect, or have too much, but with no way to control it.

One final possible bug, I've found that the histogram can sometimes get 'locked', where I can adjust an image, but the histogram won't show the changes. When this happens, you also cannot switch between Luminance and Colour view. Cancelling the Editing and reopening the image fixes this. This seems quite random, and I haven't seen a particular workflow pattern that causes this.

Cheers.

Andy
User avatar

2021-12-19 21:20:30

by Andy Hewitt 2021-12-19 20:46:28
One final possible bug, I've found that the histogram can sometimes get 'locked', where I can adjust an image, but the histogram won't show the changes. When this happens, you also cannot switch between Luminance and Colour view. Cancelling the Editing and reopening the image fixes this. This seems quite random, and I haven't seen a particular workflow pattern that causes this.

Cheers.

Andy
+1 for broken histogram at times.
User avatar

2021-12-20 12:03:31

Thanks for the in-depth feedback, Andy! We'll be looking to sort out bugs and usability issues in the following 2.0 point updates. A few more points I'd like to touch on:
The selection of the Crop tools didn't need 'fixing (where you select 'Crop', 'Straighten' and 'Perspective'), not sure why you had to hide this in a pop up menu.
Since we've made the Crop modes available from the pop-up menu on iPhone (due to limited screen real estate), it only made sense to have them selectable this way on iPad as well. Is there any particular reason you like the old Crop mode presentation better?
You've got the ML DeNoise hidden away in the drop down menu. Did you find the toolbar didn't have room to add it as a button there?
That was, indeed, one of the main reasons. In Portrait orientation, the toolbar space is quite limited both on iPhone and iPad, so we inevitably had to put some of the tools in the More menu. We have considered a customizable toolbar where you can add or remove tools you don't use but that's probably something for later versions of the app.
On the ML Denoise, is it possible to have some kind of user fine tuning? Or perhaps a more basic/manual DeNoise adjustment. I'm finding this can either have almost no effect, or have too much, but with no way to control it.
It's not possible right now but we the addition of more controls in mind for the future.
User avatar

2021-12-20 16:00:03

Since we've made the Crop modes available from the pop-up menu on iPhone (due to limited screen real estate), it only made sense to have them selectable this way on iPad as well. Is there any particular reason you like the old Crop mode presentation better?
Not really any massive reason, other than the new way seems a little clumsy in comparison. Of course I hadn't really considered too much the issue of using in Portrait mode, or on the iPhone, as I only ever use Landscape mode on my iPad Pro 12.9", or sometimes I'm on an old 27" iMac - so screen space hasn't really been an issue for me. I tend to find it's the better way round for most photo editing in order to place the tools, and the aspect of the image with the best layout for editing.
That was, indeed, one of the main reasons. In Portrait orientation, the toolbar space is quite limited both on iPhone and iPad, so we inevitably had to put some of the tools in the More menu. We have considered a customizable toolbar where you can add or remove tools you don't use but that's probably something for later versions of the app.
Ok, that's fair enough, as I said above, I tend to use the iPad in landscape almost exclusively, so hadn't actually considered that as an issue.
On the ML Denoise, is it possible to have some kind of user fine tuning? Or perhaps a more basic/manual DeNoise adjustment. I'm finding this can either have almost no effect, or have too much, but with no way to contr
ol it.
It's not possible right now but we the addition of more controls in mind for the future.
Fair enough, just a thought of course.

Best regards,

Andy
User avatar

2021-12-20 16:26:20

by Andy Hewitt One final possible bug, I've found that the histogram can sometimes get 'locked', where I can adjust an image, but the histogram won't show the changes. When this happens, you also cannot switch between Luminance and Colour view. Cancelling the Editing and reopening the image fixes this. This seems quite random, and I haven't seen a particular workflow pattern that causes this.
I've got something more consistent with this one now.

I've used a workflow like this:
• Apply ML Enhance and ML Super Res to a batch of images.
• Open an image for editing.
• Go to Crop tool to Rotate/Crop the image.
• Go to Editing tool to tweak the adjustments.
• Editing tools work (you can see the image changing) but histogram has frozen.
• Save Image and reopen, Histogram now works.

On another workflow test:
• Open image (from original).
• Apply Rotate/Crop
• Go to Edit mode, all OK.

Finally I tried this:
• Open Image.
• Apply a minor exposure adjustment.
• Go to Crop tool and Rotate
• Go to Edit tool again, Histogram is frozen.


Hope that helps,

Andy.
User avatar

2021-12-21 03:01:05

by Aurelija Since we've made the Crop modes available from the pop-up menu on iPhone (due to limited screen real estate), it only made sense to have them selectable this way on iPad as well. Is there any particular reason you like the old Crop mode presentation better?
I also preferred the previous implementation on iPad, I see the reasoning now for iPhone, it feels like the interaction on iPad with the popping menu is slower, less responsive. It may not actually be, perhaps I’m just adjusting but the original way “feels better”
User avatar

2021-12-24 05:56:49

by Andy Hewitt 2021-12-20 16:26:20
I've got something more consistent with this one now.

I've used a workflow like this:
• Apply ML Enhance and ML Super Res to a batch of images.
• Open an image for editing.
• Go to Crop tool to Rotate/Crop the image.
• Go to Editing tool to tweak the adjustments.
• Editing tools work (you can see the image changing) but histogram has frozen.
• Save Image and reopen, Histogram now works.

On another workflow test:
• Open image (from original).
• Apply Rotate/Crop
• Go to Edit mode, all OK.

Finally I tried this:
• Open Image.
• Apply a minor exposure adjustment.
• Go to Crop tool and Rotate
• Go to Edit tool again, Histogram is frozen.Hope that helps,

Andy.
Just a tiny bit more info on this.

If I use the crop tool then deselect it by clicking the icon a second time immediately after applying a crop tool function, then use the Edit panel, the histogram works fine.
User avatar

2021-12-27 08:11:42

Please DON’T accommodate the iPad version to the iPhone screen real state. Don’t do that. It doesn’t make sense to have tools hidden behind a menu option on the iPad. I found a bug too, I’ll open a thread for it.
User avatar

2021-12-27 08:19:02

Yes, that was my thought too. The layout should/needs to be contextual. Even if it meant having to purchase a different version perhaps - it’s not like Pixelmator is too expensive. Personally I never edit photos on my iPhone, so I don’t care at all about the problems of fitting to the smaller screen.

Cheers.
User avatar

2021-12-27 08:26:25

by Andy Hewitt 2021-12-27 08:19:40 Yes, that was my thought too. The layout should/needs to be contextual. Even if it meant having to purchase a different version perhaps - it’s not like Pixelmator is too expensive. Personally I never edit photos on my iPhone, so I don’t care at all about the problems of fitting to the smaller screen.

Cheers.
Exactly. Plus I have this expensive 12.9 iPad Pro with lots of screen real state and I don’t want to see the apps I use to try and accommodate the interface for an iPhone. I would gladly pay for an iPhone version too if I wanted it but as you said, I don’t edit photos on my iPhone either. I have an iPad Pro and an iMac for that.

Of course I’ll download it on my iPhone just in case there’s an urgent need for it, but I don’t see me using it often.
User avatar

2021-12-27 08:29:59

Indeed so, although to be honest, I only view on my iPhone, for which I use Apple’s own Photos app. That usually suffices until I can edit on my iPad Pro.

Otherwise I think we have an excellent overall workflow using Photos and Pixelmator alongside each other. Just a few tweaks would improve it even more.
User avatar

2021-12-27 08:34:18

Andy, have you seen the bug I posted? Do you get the same behavior with the keypad?
User avatar

2021-12-28 07:37:12

by Cantisani Andy, have you seen the bug I posted? Do you get the same behavior with the keypad?
Yes, posted a reply there. No problem here, but I’m using a UK layout, and I have my panel on the RH side.
User avatar

2022-01-14 14:06:00

by Andy Hewitt 2021-12-20 14:26:20
I've got something more consistent with this one now.

I've used a workflow like this:
• Apply ML Enhance and ML Super Res to a batch of images.
• Open an image for editing.
• Go to Crop tool to Rotate/Crop the image.
• Go to Editing tool to tweak the adjustments.
• Editing tools work (you can see the image changing) but histogram has frozen.
• Save Image and reopen, Histogram now works.
<..>
Andy, could you check if you're ruing the latest Pixelmator Photo version? There have been fixes related to this in v2.0.3.
User avatar

2022-01-14 16:06:33

by Aurelija 2022-01-14 14:06:00
Andy, could you check if you're ruing the latest Pixelmator Photo version? There have been fixes related to this in v2.0.3.
Hi Aurelija

Yes I am. Thank you, it does seem to be fixed.

regards

Andy
User avatar

2022-01-19 12:46:35

by Andy Hewitt 2022-01-14 14:06:33
Hi Aurelija

Yes I am. Thank you, it does seem to be fixed.

regards

Andy
Thanks for checking! It's good to hear it's fixed but feel free to let us know in case you notice anything else.