"Export" doesn't...

Is something not working like it should? Let us know.
User avatar

2020-08-16 18:53:31

Since upgrading to PixPro 1.7, trying to Export PNG's or JPGs from the program has become a real issue...
When I hit export, the file does not appear. I find that I have to go through the export process anywhere from 2 to 10 times before a PNG file will actually export to the desktop or designated folder.

It has become exasperating going through the export process multiple times and waiting for the exported file to appear only to realize it isn't going to happen. Along with the non-export issue, it is taking a very long time for an exported file to appear when it does.

This is happening on both my MacBook running Mojave and my MBPro running Catalina.
User avatar

2020-08-18 15:36:52

Hi there, does this happen with any file you edit (for example even empty new files) or does it seem to depend on the type of file you're exporting?

If the file is having an effect, would you be able to share it with me here or by emailing it to andriusg@pixelmator.com?

Thanks in advance!
User avatar

2020-08-18 16:46:02

Hi Andrius! Unfortunately it's happening with any Pixelmator .pxd file I use. Typically I export files for the web as PNG, however I've also tried JPG's and the result is the same.

If I shut down and restart either Mac, the first one or two files export normally, but successive exports get slower and slower until they don't export at all. The export window works as normal but the files don't appear until several attempts.

The files I'm exporting are simple 3 or 4 color block graphics, not immense photo realistic files. Image sizes are typically 11" x 17" @ 300 ppi and have always exported quickly and easily.

The MacBook runs Mojave and has 1.2ghz Intel M5 processor with 8 g's of ram. The MacBook Pro is running Catalina with Quad-Core Intel Core i7 2.5 GHz, 16 G's of RAM and a 1TB SSD drive.

If only the MacBook were having the issue I'd have assumed it was a memory issue or something else but the MacBook Pro is set up as a graphics laptop and it is experiencing the same export problem.
User avatar

2020-08-21 12:31:53

Understood, in that case, could you email us about this at support@pixelmator.com? We'll need to do some digging!