The Effects panel "Save As Default" is reverted if you remove all effects

Is something not working like it should? Let us know.
User avatar

2020-07-19 06:37:45

Repro Steps
1. Create a new document.
2. Select the Effects tool.
3. Use the dropdown menu to remove each of the default effects. (Gaussian, Zoom, Spin)
4. From the Add menu, select Save As Default.
5. Create several new layers/elements. Note that the Effects panel is empty for each.
6. Save the document.
7. Close and then reopen the document.
8. Note that the default effects are now present for all but the original background layer. They are also present for every newly-created layer/element.

Expected Behavior
The "Save As Default" function persists my chosen set of Effects, including no effects at all.

Actual Behavior
If you remove all effects, the "Save As Default" function only persists as long as the current document is open.
User avatar

2020-07-20 07:19:23

Hey Dan. That doesn't seem to be easily reproducible on our end. Would you be able to share a screencast with the repro steps and your Pixelmator Pro version at support@pixelmator.com? Thanks!
User avatar

2020-07-20 09:31:13

by Aurelija 2020-07-20 14:19:23 Hey Dan. That doesn't seem to be easily reproducible on our end. Would you be able to share a screencast with the repro steps and your Pixelmator Pro version at support@pixelmator.com? Thanks!
Done! In checking the brand new PixelMator 1.7, I found that you must actually quit the app altogether in step #7 rather than just closing/reopening the document.
User avatar

2020-07-20 12:46:07

Thanks, successfully reproduced. Nice catch!