Rastor to pixel conversion disappearing

Is something not working like it should? Let us know.
User avatar

2020-06-05 21:44:41

The thread title tells the story. In pixelmator pro, I create a shape (in this case a single ellipse). Then with that layer selected, I click into Format > Convert to Pixels and - poof - the image disappears. (At least when I do Edit > Undo, it comes back, so no problem there.)
I've tried a couple work-arounds but to no avail. I also read one of the suggestions in this forum about opening a blank layer and merging that with the vector layer .. sounded ingenious. But that didn't work for me in this case either. Nice try by that poster, tho.

For the past couple years I've been pretty exclusively doing photo-related things; I haven't worked with the vector side of PPro much at all yet .. like essentially zero. So I've been assuming operator error up to this point. But I've read through the manual and checked out the posts, and I'm beginning to think it might be a glitch?

Specs: I''m running PPro version 1.6.4 Magenta on a MacBook Pro, 28 GB of memory left out of 250gig, operating on Catalina 10.15.4.

"Pls help me Mister Wizard." (I know, that dates me.)
User avatar

2020-06-06 15:33:31

FYI: This does not happen with my iMac 27" Retina (Late 2014) , 32 GB, MacOS 10.15.4 with PixPro 1.6.4 Magenta
User avatar

2020-06-08 07:23:39

Hi Jim! I have a feeling your layers might have some effects applied to it or some specific layer styling as, at least right now, this doesn't seem to be a particularly widespread issue and I'm also unable to repro... Would you be able to share a screen recording of the issue along with your system specs? Here's how you can record your screen:


Once you've done that, you can upload the file to http://upload.pixelmator.com then copy and paste the link that appears on that page into your reply here.
User avatar

2020-06-10 20:22:38

Thanks Andrius. Here 'tis, below.

btw, to simplify (you had an interesting idea about some of the other pixel layers maybe having some masking effects, etc), I simplified the whole thing to eliminate those variables, as you'll see on the video. I started with a new PPro document, where there is just a background layer and then a single working layer. You'll see that I select a shape (ellipse in this case), it shows up as expected, and then when I convert to pixel, poof.

Again, I won't be surprised if it's operator error.

My system specs you'll see in my original post above. To mccoytest's point (good point thx, I had omitted), I'm on a Retina 15", mid-2015 model. I've worked some with vectors on this machine a little bit in the past and haven't had this problem.

Here's the screen vid. (Let me know if it doesn't come through to you. I replayed it on this end before uploading and it recorded fine.) Thanks again.
User avatar

2020-06-11 13:43:42

Ah, yes, I can see your specs in the original post, my apologies. As for the video — it looks like it didn't come through, unfortunately... However, I can see a link to a Pixelmator Pro file and, in it, there's a vector shape but it has no associated style (stroke/fill). If you're converting that to pixels, it will end up empty as the outline displayed when selecting that layer is there just for convenience, the shape itself has to have some styling applied to it. If you choose the Style tool, add a stroke layer style for example, and then convert the layer to pixels, everything should work correctly.

Hope that helps!
User avatar

2020-06-11 20:11:25

Thanks much, Andrius. As I said, operator error. And your explanation got across the concept to me: the initial shape is just the math equation graphed out as a convenient visual reference, before selecting a style to be overlaid onto it. I will remember.

Have a great day. Jim

ps not sure why the video didn't come out. But I'm glad you followed the rabbit trail to see a snapshot and deduce from that. Excellent.