Purchased app, stuck on "Buy Now" end of trial screen

Is something not working like it should? Let us know.
User avatar

2019-12-22 17:15:03


I tried the pro app, the trial ended, I purchased the app but it won't move past the end of the trial screen. I click Buy Now (even though I already paid for it), go to app store, can't download again or proceed. The "Open" button on the app store takes me to Pixelmator.com or to my own desktop. If I'm taken to the desktop, the app icon is grayed out.

I then remove the app and it starts all over again.

Has anyone else had this experience?

Thank you,

User avatar

2019-12-27 11:39:08

Hi Vee, I don't think I've come across an issue like this before but my advice would be to completely remove every copy of Pixelmator Pro from your Mac (move them to the Trash > Empty Trash), then try downloading the app again from the Mac App Store.
User avatar

2019-12-27 12:31:42

Hi, Andrius, Happy Holidays! It is very nice to meet you

I did that a few times, it was the same result but we have a happy conclusion to the story. I ran out of time and decided to continue working with my old version of Pixelmator, leaving the last install of Pro in place. When I opened the first image it opened in Pro! So it ended well. I still can't tell why I was stuck in that series of events, but it is working great and I love it!

Thank you very much for a wonderful app and for answering my question!