Virtually Unusable On Brand New Macbook Pro 16inch

Is something not working like it should? Let us know.
User avatar

2019-11-26 20:23:06

I recently upgraded to the new 16 inch MBP. I have been using Pixelmator Pro since its release, and the OG pixelmator before that. Currently, I can't accomplish ANYTHING because with every single new layer, or edit to a current layer, the project begins to glitch and pixelate more and more until the entire project is one big mess. I NEED HELP as this is my primary editing/design software. For the record, I have thoroughly tested all my other apps, including design software (photoshop etc.,) and Pixelmator Pro is the only one having any issues. I have attached a screenshot for reference, if anyone can help me. PLEASE!!! And thank you.
User avatar

2019-11-26 20:25:22

I tried to attach the screenshot but unless I'm missing something, it looks like nothing happens when I do.
User avatar

2019-11-27 07:00:17

can confirm... this is what I see, if attaching an image works. This was a full block cutting and pasting layers.



Image
User avatar

2019-11-27 09:35:50

Hey there, a fix for these issues will be included in Pixelmator Pro 1.5.3 and we'd be happy to send you a beta version of it in the meantime — please send us a quick email about this at support@pixelmator.com and we'll help out!
User avatar

2019-11-27 13:17:54

Great, thanks Andrius
User avatar

2019-12-02 15:49:12

That fix is now available on the Mac App Store — hope it's working for you!