Error when trying to update to version 1.5 with iMac (27 inches, end of 2013) and macOS Calatina (19A583) final version

Is something not working like it should? Let us know.
User avatar

2019-08-22 19:04:23

I use an iMac (27 inches, late 2013) to do design work with the Pixelmator Pro application (version 1.4). This iMac has the graphic Nvidia GeForce GTX 780M 4GB and I am using macOS Catalaina (10.15 19A583).

When I try to update Pixelmator Pro to the latest version (1.5) I get an error that tells me: "Pixelmator Pro is incompatible with the graphics card of this computer"

I would like to know if my mac is going to be incompatible with future Pixelmator Pro updates, or is it a bug?
User avatar

2019-08-23 13:12:12

I have been getting the same error message on my iMac (21.5-inch, Late 2013) as well when trying to update. Mine has a NVIDIA Geforce GT 750M 1 GB. I am also running the latest macOS Catalina 10.15 (19A536g).

Thank You
User avatar

2019-08-27 16:17:57

This is a known issue that we've reported to Apple — it's on its way to being fixed but, if you haven't done so already, could you also shoot us an email about this at support@pixelmator.com with your Apple IDs? Thanks!
User avatar

2019-10-09 07:45:55

Still the same, won't install …
User avatar

2019-10-10 11:38:11

Still the same here with late 2013 iMac 27'', GTX 775M, 2GB.
User avatar

2019-10-10 12:37:53

Unfortunately, this issue still hasn't been resolved in macOS Catalina, but we can send anyone affected a directly downloadable version if you could email us at support@pixelmator.com.
User avatar

2019-10-11 12:05:35

with the last version of pixelamtor 1.5 and the final version of macOS Calatina the error continues. Is my mac obsolete and I will no longer be able to use pixelamtor pro even though I bought it?

I think it's a very serious problem, since the nvidia GPU is still powerful so that you can use a program like pixelmator pro as with version 1.4.
User avatar

2019-10-30 03:20:23

I have and run Pixelmator Pro Version 1.4.1 on my 5,1 Mac Pro with a Metal compatible graphics card. But when I try to update to Version 1.5.1, I get a message saying the App Store is unable to complete my purchase. What gives? The App store is continually telling me I have an update available, but I am unable to do so.
User avatar

2019-11-01 09:14:59

by iGarikoitz 2019-10-11 12:05:35 with the last version of pixelamtor 1.5 and the final version of macOS Calatina the error continues. Is my mac obsolete and I will no longer be able to use pixelamtor pro even though I bought it?

I think it's a very serious problem, since the nvidia GPU is still powerful so that you can use a program like pixelmator pro as with version 1.4.
Your Mac is most certainly not obsolete — this is, hopefully, a temporary App Store bug. If you haven't yet done so, we'd love it if you could email us about this at support@pixelmator.com.
by Robert Worthingham 2019-10-30 03:20:23 I have and run Pixelmator Pro Version 1.4.1 on my 5,1 Mac Pro with a Metal compatible graphics card. But when I try to update to Version 1.5.1, I get a message saying the App Store is unable to complete my purchase. What gives? The App store is continually telling me I have an update available, but I am unable to do so.
Could you also send us an email about this at support@pixelmator.com?

Thanks!