Can't fully delete selection

Is something not working like it should? Let us know.
User avatar

2018-05-20 19:16:13

I'm a long-time Pixelmator user (4 years) and bought Pixelmator Pro as soon as it was released. I really want to love it, but I keep finding bugs that always make me reach for Photoshop to get the job done.

Something new is happening that has never happened before. Here are the steps to reproduce:
1. Use the Quick Selection or Select Color tool to create a selection.
2. Press Delete to clear the selection.

--> the selection is cleared but only about 90% of looks like a ghost image is still left behind. If I delete again, more of the selection is cleared, but still not all. I can eventually clear what seems to be 100% (but is probably only 99.9999%) after hitting Delete about 20 times.

Why does this happen?

Selecting: Image
After pressing Delete: Image
User avatar

2018-05-20 19:22:18

In addition...every time I clear a selection, the ENTIRE IMAGE (not just the selection) gets darker (as if clearing the selection also reduces the exposure of the image about 10%.
User avatar

2018-05-20 19:30:55

OK... that's weird. I grabbed your first image, used quick select to select the webbing and got no ghosting and no darkening of the image. Let's see if we can figure out what's going on... if not it'll have to wait for the Pixelmator staff.

1. Does this happen on other images or just here?
2. Does the image have more than one layer?
3. If you do what I just did, do you get the same result?
(I'm getting a white background because I exported the image and the transparency is showing the white page underneath.)

User avatar

2018-05-20 19:35:18

Hi st3f...only the one does happen on other images, but not all (this one was exported from Photos, and another that I tried wAs also exported from Photos, but I tried with an image that was pulled from the Internet and couldn't reproduce). Here's the original image if you want to try: ... 1.jpg?dl=0
User avatar

2018-05-20 19:45:59

Hi Deralict.

I've just grabbed the image from drop-box and it's being annoyingly well behaved. I'm approaching this from the angle of: If I wanted to intentionally do what your copy of Pixelmator Pro is doing, how would I do it? I'm struggling to think of anything so try to get our copies of Pixelmator Pro as close as possible and see if we can get them behaving in the same way.

First check versions: Pixelmator Pro 1.0.9 on macOS 10.13.4

Then try to do this as clean as possible:
1. Close all files open in Pixelmator Pro
oops: 1a Close Pixelmator Pro.
2. Visit the dropbox link you gave me.
3. Right click on the image and copy it.
4. Open PP and under new file select clipboard.
5. Select the area using Quick select.
6. Hit delete.
What do you see?
User avatar

2018-05-20 19:51:27

OK, the plot thickens. PP and macOS version match up.

Following your steps, I could NOT reproduce.

Try this, as this IS how I can reproduce:

1. Download the image to your Mac.
2. Make sure PP is open.
3. Drag the file to the PP icon to the PP icon to open it.
4. Select the area, hit Delete.
User avatar

2018-05-20 20:00:43

First the good news: I can reproduce the effect with that image.
Slightly less good news. I haven't managed to reproduce it with any other... yet.

I think you have a genuine, annoying, pesky little bug and a way of reproducing it.

The question is, do you have a reasonable work-around? Can you open the image without getting the effect (without uploading it to dropbox)?

For me File > Open... still shows the problem.
User avatar

2018-05-20 20:05:35

The following does not show the problem (but is a pain).
1. Create new image.
2. Use Insert > Choose... to load the image.
3. Use Tools > Reveal Canvas to get the whole image revealed.
User avatar

2018-05-20 20:17:39

it seems like when the image is opened the traditional way, the problem occurs. Copying-> New image from clipboard or the Insert > Choose workarounds are just that, and I think they are really just putting a collection of pixels into the app. They are OK for now, but not good long-term solutions. I would really like this bug to be fixed.

I think I will also post some other bugs that have been bothering me, that I have just lived with so far.
User avatar

2018-05-20 20:28:45

They are OK for now, but not good long-term solutions. I would really like this bug to be fixed.
Absolutely. Workarounds should always be temporary. Here's hoping it's fixed soon.

It is a weird little bug, though. I thought it might be a malformed jpeg that Pixelmator Pro stumples over so I tried the following.
I loaded the file into Preview, flipped it horizontally (which I hope should trigger a fresh reformat of the file) and got the same problem. I even converted it to a png and that didn't solve it either.

This certainly is strange. Anyhow, I'm going to leave this now. I hope the guys at Pixelmator can reproduce, isolate and solve. I'd recommend sending them an email ( with the file and a link to here, just to make sure it gets into their bug-tracker promptly.

Best of luck.

- Stef.
User avatar

2018-05-20 20:38:40

Will do...thanks!
User avatar

2018-05-21 15:23:56

Hey gang, good news — we reproduced the bug and it has actually already been fixed in the latest internal beta. It was happening due to some inconsistencies with how images with the Apple Wide Color Sharing profile were handled.