macOS 1.0.8 Update causing graphics glitching

Is something not working like it should? Let us know.
User avatar

2018-02-05 06:23:16

Updating Pixelmator Pro to 1.0.8 introduced two issues I had not seen before. The first was that it said I could not apply a color adjustment on a group - that it needed to be merged first. This is a feature I've been using since the beginning, and I'm hoping this is some accidental bug and not taking away that feature. Secondly, the repair tool was causing a lot of random lines to appear on the layer I was repairing.

I have a Mac Pro (2013) with two D700s.
User avatar

2018-02-05 08:14:44

Hmm, you should definitely be able to apply color adjustments to layer groups, but it may be something about the file itself that could be causing this, so could you share it with us at As for the graphical glitches, again, the file you're editing would be useful so we could try to reproduce the issue.
User avatar

2018-02-05 17:32:33

I went to recreate the issue this morning (I had shut down my Mac, and restarted it this morning), and I can't do it. So the restart cleared up whatever the issue was... Neither bug was present.

To answer your question, though. The file format should not have been an issue because the same exact file that was causing an issue in 1.0.8 worked fine when I opened it in 1.0.7 - it was a 32-bit TIFF, if that makes a difference. That was the only file I tried opening at the time. If I encounter it again, I will try other files.
User avatar

2018-02-06 08:41:49

I spoke to the lead dev about this and he mentioned the group merging thing might have been an issue in 1.0.7 but should have been cleared up in 1.0.8 (it was one of the reasons why that update came out so quickly...). So it's possible you may have seen the update for 1.0.8 while still having 1.0.7 on your Mac.