"New from Photos" doesn't work

Is something not working like it should? Let us know.
User avatar

2018-02-04 13:11:00

When I try to open a new image from photos I get an endlessly spinning wheel: Image



Is this a known bug, and is there a way to fix it?
User avatar

2018-02-04 20:33:47

Works for me. Took a long time (minutes) the first time I tried it. I'm not sure if there's an index or something being built. It still takes a while (15 seconds or so) but I am running this on a rather underpowered 12" MacBook.

Of course it could be a function of the size of the database. My Photos database is just under 45GB according to System Preferences... > iCloud.
User avatar

2018-02-05 08:32:11

It's most likely not a case of the size — we had an issue with larger Photos libraries in v1.0 but that was fixed fairly quickly because it was easily reproducible. This bug seems pretty random and as far as we've managed to reproduce it, either closing the window and trying File > New from Photos again or choosing a different album/collection loads the library. If the library consistently doesn't load for you no matter what you do, logs from the Console would be useful, so if you could email us at support@pixelmator.com, we'd give you the steps for capturing the logs.
User avatar

2018-02-05 08:51:47

I left it to spin during the night, and in the morning it finally displayed the library. Unfortunately, it seems to repeat the same process every time I use the option. Since I'm always editing photos from the Photos app, there should be a better way of doing this, for example loading only the most recent photos or just having an option to load an album.