Pixelmator Pro works only on MacOs 15, needed to work on Mojave as well

What features would you like to see in Pixelmator Pro?
User avatar

2021-11-23 18:47:50

Could you please make it to work on Mojave MacOs 10.14.6 as well?
I cannot update to the 2.3 version.
PLEASE
User avatar

2021-11-24 12:50:22

I have 2.2 running, and I guess I could live with that, but I just recommended some other people to buy Pixelmator Pro at 50% discount - and some of them can't. They are on Mojave still as Catalina breaks compatibility with other apps such as Aperture. Ah, well, Aperture is old, but some people stick to it.

I'll try updating on another computer and see if I can copy the files, in case it's an "artificial" limitation.
User avatar

2021-11-24 13:56:26

Pixelmator Pro 2.2 is the last version compatible with macOS Mojave. We support up to 3 macOS versions at a time to make sure Pixelmator Pro runs smoothly on each one. Besides, the new features in v2.3 are built using certain frameworks that aren't available on older macOS versions and we honestly wouldn't want to offer a version of Pixelmator Pro that's not full-featured.
User avatar

2021-11-24 14:13:40

Too bad !
User avatar

2021-11-24 14:16:28

I know. You should still be able to use Pixelmator Pro 2.2, though!
User avatar

2021-11-24 14:17:06

by Citadell 2021-11-24 20:50:22 I have 2.2 running, and I guess I could live with that, but I just recommended some other people to buy Pixelmator Pro at 50% discount - and some of them can't. They are on Mojave still as Catalina breaks compatibility with other apps such as Aperture. Ah, well, Aperture is old, but some people stick to it.

I'll try updating on another computer and see if I can copy the files, in case it's an "artificial" limitation.
Same here! CancerLina is a disaster and I recommended it to a few friends of mine . They will be disappointed.
User avatar

2021-11-24 18:10:04

@Aurelija - you might need to update sys-specs in the App Store; still telling Metal2 compatible Mac with at least HighSierra.
User avatar

2021-11-25 10:54:12

by EllenM @Aurelija - you might need to update sys-specs in the App Store; still telling Metal2 compatible Mac with at least HighSierra.
Doing it right now. Thanks for the heads-up!