color fill grows my image

Talk about Pixelmator Pro, share tips & tricks, tutorials, and other resources.
User avatar

2020-01-05 20:40:41

i set my image size to be 1200x280. i clear the background layer & then fill with a single color. now its 1202x282. i've deselected Smooth Edges. this is not acceptable behavior; i want the image to be the size i want, not the size PP decides it will make it.
User avatar

2020-01-05 21:40:10

That's strange. I just went through your steps and the canvas size remains 1200x280.
User avatar

2020-01-05 21:44:19

I can't replicate either. @tabarnart can you give the exact steps that show this problem (including version numbers of Pixelmator Pro and macOS that you are using)?

The community's pretty good here and we'll help if we can.
User avatar

2020-01-05 23:27:35

i tried it with a new document from scratch; no problem. i think it might be because the original image was much bigger; i cropped it down (and i'm sure i used delete not hide) and so, as i edited it (prior to seeing this problem) it had what looked like a selection of the original image. so i think it "remembers" that original image in some way and is doing something goofy when i try to "fix" the background layer.

solution: start with the final image size, i guess.

thanks!
User avatar

2020-01-06 12:12:55

I tried to replicate this with a cropped image and wasn't able to but it does sound like you probably came across a bug there. If it does happen again and you can replicate it — we'd really appreciate it if you could share any specific steps that cause this to occur.
User avatar

2020-01-06 16:00:53

i think this has to do with "trim canvas" which i had forgotten about & didn't try to use. i think if i had done that, i'd have had no problem.